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  Version       Date                                                          Remarks 
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[Fix] Optimised handling of tariff IDs in the Novalnet API configuration when 

loading a single tariff 

[Enhanced] Offering Instalment payments and Guarantee payments to B2B 

customers in Switzerland  

[Enhanced] Extension of Instalment cycles till 36 cycles 

[Enhanced] Built-in Sub-Resource Integrity (SRI) integrated for JavaScript files to 

improve security for preventing unauthorized modification 

[Enhanced] Minification of CSS and JavaScript files for enhanced performance. 

[Enhanced] Optimized the Callback/Webhook process for fetching the Dynamic IP. 

[Removed] Sofort, giropay, and Barzahlen/Viacash payments 

For the previous version changelog, go to https://github.com/Novalnet-AG/gravityforms-payment-

integration-novalnet/blob/master/changelog.txt
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1 QUICK SETUP 

This guide describes the quick installation procedure of the Novalnet payment plugin (this guide comes 

along with the plugin), to integrate it with your shop system and to start accepting payments worldwide. 

For this integration, a Novalnet merchant account is required to accept Novalnet payments. Please ensure 

that you have received your merchant account details from our sales team. If not, drop an email to 

sales@novalnet.de  

This Novalnet payment plugin package version (3.2.0) supports the following versions: 

   

6.0 - 6.8.2 2.3 - 2.9.17.1 3.2.0 

 

To get started: 

1. Log in to the Novalnet Admin Portal with your merchant account details (user credentials) 

2. Log in to your Gravity Forms shop system. 

3. Make sure that you have extracted the payment plugin package from the zip file you have 

received. If you have received only the installation guide without the payment plugin package (zip 

file), please send us an email to technic@novalnet.de with your merchant ID. 

1.1 Plugin Installation 

To install the Novalnet Payment Plugin, please go to your shop system and follow the steps below. 

Step 1: Navigate to Plugins → Add plugin in your shop admin panel as shown below 

 
  Figure 1 

Step 2: Next to Add Plugins, click Upload Plugin. 

 
Figure 2 

mailto:technic@novalnet.de
mailto:sales@novalnet.de
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Step 3: In the next window that appears, click Browse and choose the file novalnet-payment-add-on-for-

gravity-forms.zip included in the Novalnet Gravity Forms plugin package. Click Install Now to upload it 

into your shop system. 

  
Figure 3 

Step 4: After the installation, click Activate Plugin as shown below, 

  
Figure 4 

1.2 Upgrading the Novalnet payment plugin 

 You can get the updated plugin directly from the WordPress forum, by contacting our technical team, 

or via the Novalnet homepage. 

 An earlier version of the Novalnet payment plugin should be installed in the shop to 

synchronize with the WordPress forum update. 

Follow the steps below to update the latest Novalnet payment plugin – Gravity Forms via the shop 

admin panel 

Step 1: Navigate to Plugins→ Installed plugins in your shop admin panel as shown below. 

 
Figure 5 

Step 2: Under the Novalnet payment Add-On for Gravity Forms, click update now as shown below

 
Figure 6 
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Now, the updated version of the Novalnet payment Add-On for Gravity Forms will be displayed as 

shown below. 

  

Figure 7 

Step 3: After installing or upgrading the Novalnet payment plugin- Gravity Forms and click Settings as 

shown below. 

 

Figure 8 

1.3 Global Configuration in the Gravity Form shop system 

The main configuration occurs in your Gravity Form shop system as well as in the Novalnet Admin Portal. 

In your Gravity Form shop system, navigate to Forms → Settings → Novalnet. Enter the following keys as 

given below: 

 Product activation key - a unique token for merchant authentication and payment processing. 

 Payment access key - a secret key assigned to each merchant that encrypts the data to avoid user 

manipulation and fraud. 

 Tariff ID - a unique identifier created based on the tariff type at Novalnet. 

 
Figure 9 

To get your Product activation key and Payment access key, go to the Novalnet Admin Portal, navigate 
to the Projects menu, and click the view icon on the right of your project to view the project details. 

 
Figure 10 
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Click API credentials, copy the API Signature (Product activation key) and Payment access key. Create a 

Tariff ID for each tariff type for the webshop. 

 
Figure 11 

Paste the Product activation key and Payment access key in the respective fields in your shop system. 

Next, choose the Tariff ID from the drop-down menu that you have created in the Novalnet Admin Portal 

for this Gravity Form shop system. 

 
Figure 12 

Then click  to update the changes. 

1.3.1 Notification/Webhook configuration in the Novalnet Admin Portal 

In the Novalnet API Configuration page on your shop system, you will find your Notification / Webhook 

URL under Notification / Webhook URL Setup. Click Configure to link your Notification / Webhook URL 

to the Novalnet Admin Portal, as shown below 

 
Figure 13 
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After successful configuration, your shop Webhook URL will be linked with your Novalnet Merchant 

account, which can be seen under Vendor script URL/ Notification & Webhook URL field under API 

credentials of your project, as shown below 

 
Figure 14 

In your shop system, you can additionally test the Webhook URL manually and send notification emails to 

specific email addresses, as shown below 

  
Figure 15 

 Notification/Webhook URL - Required to keep the merchant’s database/system up to date and 

synchronized with Novalnet (for example: up-to-date transaction status delivery). 

 Allow manual testing of the Notification/Webhook URL - Enable this to test the Novalnet 

Notification/Webhook URL manually. Disable this before setting your shop system live to block 

unauthorized calls from external parties. 

 Send e-mail to - Every execution will be sent as a message to the e-mail address defined in this field. 

  

mailto:technic@novalnet.de


 

 

 

 8 

NOVALNET AG 

Payment Institution 

Gutenbergstr. 7  

D-85748 Garching 

Tel.: +49 89 9230683-19 

Fax: +49 89 9230683-11 

E-mail: technic@novalnet.de 

Tax id: DE254954139 

Board of Directors: Gabriel Dixon (CEO), Johnson Rajdaniel (CFO) 

Chairman of the supervisory Board: Frank Haussmann 

Commercial register number: HRB 167381 

1.4 Payment Activation in the Novalnet Admin Portal 

All the Novalnet-supported payment methods can be viewed here: www.novalnet.com/payment. If you 

have questions on the payment methods or have additional payment method requests, please contact 

sales@novalnet.de 

To activate the preferred payment methods for your website, navigate to Novalnet Admin Portal → 

Projects → Choose your projects → Payment Methods → click Edit Payment Methods in the top right 

corner as shown below 

 
Figure 16 
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Now select the preferred payment methods and click Update to activate them. 

 
Figure 17 

To use the Apple Pay payment method, go to Apple Pay → Configure → Add new domain in the Novalnet 

Admin Portal, as shown below 

 
Figure 18 
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Then, paste the https://paygate.novalnet.de/ domain to enable Apple Pay, and click verify as shown 

below. 

 
Figure 19 

To use the PayPal payment method, configure the PayPal API details in the Novalnet Admin Portal as 

shown below 

 
Figure 20 

To use the PostFinance payment method, configure Ep2-Merchant ID details in the Novalnet Admin Portal 

as shown below 

 
Figure 21 
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1.5 Payment Configuration in the Gravity Form shop system 

Soon after the activation of payment methods in the Novalnet Admin Portal, you must enable those 

payment methods in your shop system to display them on your Gravity Forms checkout page. Navigate to 

Forms → Settings as shown below 

 
Figure 22 

In the settings page, click the Novalnet tab as shown below 

    
Figure 23 
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Figure 24 

Refer to Chapter 4 ADDITIONAL CONFIGURATION for more payment configurations. 

 If you have any recommendations or suggestions for improvement, kindly share your thoughts with 

us at technic@novalnet.de or call us at +49 89 9230683-19. 

 Are you happy with our service and support? Please spend a few minutes sharing your success here. 
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1.6 Novalnet Feed configuration for One-time transaction orders 

To create the Novalnet feed for one time transaction orders, follow the steps below, 

Step 1: Navigate to Forms → Select Forms to create the novalnet feed, which is mandatory to proceed 

with the one-time transaction order. 

 
Figure 25 

Step 2: Choose Settings → Novalnet, under the respective form. 

 
Figure 26 

Step 3: To create the new Novalnet feed. Click create one! as shown below 

 
Figure 27 
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Step 4: Select Products and Services in the Transaction Type to process one-time transaction orders. 

    
Figure 28 

Step 5: Make sure that all the fields are selected under the Other Settings. Finally, click Save Settings to 
update and activate the feed configuration as shown below 

 
Figure 29 
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1.6.1  Novalnet Feed configuration for Subscription 

To create a Novalnet feed for subscription orders, follow the steps below, 

Step 1: Refer to Steps 1 to 3 from Chapter 1.6 Novalnet Feed configuration for One-time transaction 

orders to create the Novalnet feed for the Subscription order. 

Step 2: Select type as a Subscription in the Transaction Type to process subscription transactions and 
provide the other details in the Subscription Settings. 

                
Figure 30 

Step 3: Make sure that all the fields are selected under the Other Settings. Finally, click Save Settings to 
update the settings. 

  
Figure 31 
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2 README PROCEDURES 

2.1 To display the Novalnet transaction details 
Follow the steps below to display Novalnet transaction details in the shop order mail. 

Step 1: Navigate to Forms →Forms,  under the respective form, navigate to Settings → Notifications 

Step 2: Under User Notification, click Edit as shown below 

   
Figure 32 

Step 3: Under the Message block, click  and search for Novalnet, and choose Novalnet Payment 

Details. 

 
Figure 33 

Step 4: Place Novalnet payment details tag {payment_action:novalnet_transaction_note}  as you wish 

in the content and click Update Notification as shown below 

 
Figure 34 
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2.2 To display the Novalnet transaction details on the order confirmation page 

Follow the steps to display Novalnet transaction comments on the order confirmation page 

Step 1: Navigate to Forms →Forms, under the respective form. Further, Navigate to Settings → 

Confirmations 

Step 2: Under Default Confirmation, click Edit. 

 
Figure 35 

Step 3: Under the Message block, click  and search for Novalnet add Novalnet Payment Details as 

shown in below 

  
Figure 36 
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Step 4: Place Novalnet payment details tag {payment_action:novalnet_transaction_note} as you wish in 

the content and click Save Confirmation as shown below 

 
Figure 37 

3 TESTING AND GOING LIVE 

Execute test transactions by navigating to Forms → settings →  Novalnet and check Enable test mode in 

the Novalnet API Configuration page. In the test mode, the transaction amount will not be charged by 

Novalnet. 

 
Figure 38 

 Refer URL below for the Novalnet test payment data for testing  

https://developer.novalnet.com/testing 

 Execute orders in LIVE MODE 

To proceed with LIVE orders, navigate to Forms → settings →  Novalnet and uncheck the Enable test 

mode in the Novalnet API Configuration. 

 If you have any recommendations or suggestions for improvement, kindly share your thoughts with 

us at technic@novalnet.de or call us at +49 89 9230683-19. 

 Are you happy with our service and support? Please spend a few minutes sharing your success here. 

  

mailto:technic@novalnet.de
https://developer.novalnet.com/testing
mailto:technic@novalnet.de
https://wordpress.org/support/plugin/novalnet-payment-add-on-for-gravity-forms/reviews/


 

 

 

 19 

NOVALNET AG 

Payment Institution 

Gutenbergstr. 7  

D-85748 Garching 

Tel.: +49 89 9230683-19 

Fax: +49 89 9230683-11 

E-mail: technic@novalnet.de 

Tax id: DE254954139 

Board of Directors: Gabriel Dixon (CEO), Johnson Rajdaniel (CFO) 

Chairman of the supervisory Board: Frank Haussmann 

Commercial register number: HRB 167381 

4 ADDITIONAL CONFIGURATIONS 

4.1 Additional configuration for all the payment methods 

For additional payment configuration settings for each payment method, navigate to Forms →  Settings, 

click Novalnet, and configure the required additional payment settings. 

Payment Action (Debit immediately / Reserve funds for later) 

 This option is available only for Credit/Debit Cards, Direct Debit SEPA, Direct Debit SEPA with 

payment guarantee, Instalment by Direct Debit SEPA, Invoice, Invoice with payment guarantee, 

Instalment by Invoice, PayPal, Apple Pay, and Google Pay. 

You can choose between two options - Capture and Authorize, which are both explained below. 

 Capture - This is the default setting where payments are directly executed, and funds are automatically 

transferred from the buyer’s account to the merchant account. This can be changed as per your 

business requirements. 

 
Figure 39 

 Authorize- Payment details are verified while the funds are reserved, which will be captured later. 

 Minimum transaction amount for authorization - Transactions from this amount will be “authorized” 

(reserved) only and captured later. Leave the field blank to authorize all transactions. 

 
Figure 40 

Payment due date (in days) 

Payment due date (in days) refers to the duration (number of days) given for the buyer to complete the 

payment. The payment process and duration may differ for each payment method. 

 This option is available only for Direct Debit SEPA, Invoice, and Prepayment. 

 
Figure 41 

 For Direct Debit SEPA, enter the number of days after which the payment is debited (must be between 

3 and 14 days). 

 For Invoice, enter the number of days given to the buyer to transfer the amount to Novalnet (must 

be greater than 7 days). If this field is left blank, 14 days will be set by default. 

 For Prepayment, enter the number of days given to the buyer to transfer the amount to Novalnet 

(must be between 7 days). If this field is left blank, 14 days will be set by default. 
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Enforce 3D secure outside EU 
By enabling this option, all payments from cards outside the EU will be authenticated via 3DS 2.0 SCA. 

 
Figure 42 

Instalment cycles 

An instalment cycle refers to the pre-defined period for partial payments that allows the buyers to pay 

their full order amount in parts. The intervals or cycles vary based on the shop admin configuration. 

This option is available only for Instalment by Direct Debit SEPA and Instalment by Invoice. 

Define which instalment cycles you wish to offer in your shop (e.g.,2 cycles, 3 cycles, 4 cycles, 5 cycles, 6 

cycles, 7 cycles, 8 cycles, 9 cycles, 10 cycles, 11 cycles, 12 cycles, 15 cycles, 18 cycles, 21 cycles, 24 cycles, 

36 cycles etc.,.) and click Save Settings. The buyer can then choose among these instalment cycles if they 

wish to pay in instalments. 

 
Figure 43 

The pre-defined instalment details will be visible for the buyer under the chosen instalment payment 

method, as shown below 

 
Figure 44 
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5 CUSTOM FIELD CREATION FOR GUARANTEED AND INSTALMENT PAYMENTS 

5.1 Date of Birth Field Creation (B2C) 

During the form creation, create the Date of birth field, which is mandatory field to proceed with the 

guaranteed and instalment payments. 

Step 1: Go to Forms  under the respective form, choose Edit → Add Fields → Advanced Fields → Date, 

drag and drop the date field 

  
Figure 45 

Step 2: Choose settings  under the Date field.  

  
Figure 46 

Step 3: Next, enable the Required check box under the General tab to display the Date of birth field as a 

mandatory field in the shop front end. 

   
Figure 47 
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Step 4: Then, choose the Advanced tab, in the Admin Field Label, provide the field value, Eg., “Birth Date”.  

   
Figure 48 

Step 5: Click    button to update changes. 

Step 6: To view the Novalnet Feeds, navigate to Forms, under the respective form, click Settings → 

Novalnet from the list. 

  
Figure 49 

Step 7: Click Edit under the respective Novalnet Feed as shown below 

 

Figure 50 
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Step 8: Make sure the Birth Date is added to the Birth Date field under Other Settings. Finally, click Save 

Settings to update the settings 

    
Figure 51 

5.2 Company Name Field Creation (B2B) 

During the form creation process, create the Company Name field as a mandatory field to proceed with 

the guaranteed and instalment payments for B2B. 

Step 1: Navigate to Forms under the respective form, choose Edit → Add Fields →Post Fields → 

Custom Field. 

  
Figure 52 

Step 2: Choose settings  under the Post Custom field as shown below 

  
Figure 53 
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Step 3: Under the General tab, edit the “Field Label” text as you wish and enable the Required option to 

display the Company Field as a mandatory field in the shop front end. 

  
Figure 54 

Step  4: Then, choose the Advanced tab and enter the Company Name in the Admin Field Label 
field. 

  
Figure 55 

Step  5: Click  for changes. 

Step  6: To view the Novalnet Feeds, kindly go to Forms, click the respective form and click Settings → 
Novalnet from the list. 

  
Figure 56 
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Step 7: Click Edit under the respective Novalnet Feed as shown below 

 
Figure 57 

Step 8: Make sure the Company Name is added to the Company Name field under Other Settings. Finally, 

click Save Settings to update the settings 

 
Figure 58 
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6 MANAGING GRAVITY FORMS ADMIN PANEL 

6.1 Entries management 

To view the entries, kindly navigate to Forms → Entries in the shop admin. 

 
Figure 59 

6.2 Entries overview 

To view the entries for the respective form. Click the Entries as shown below 

 
Figure 60 

Now, you can review the transaction details of the respective entries under Payment Details.   

 
Figure 61 
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6.3 Entries details for Instalment payments 

To review the completed and pending payments for a particular instalment entries, click the entries 

number, select the respective entries and scroll down to the Novalnet Instalment section, as shown below 

  
Figure 62 

7 MANAGING SUBSCRIPTION 

You can create a subscription automatically through Novalnet, either based on the predefined settings in 

the Novalnet Admin Portal or through the dynamic subscription creation parameters passed during the 

initial API request, and execute automated follow-up debits via supported payment methods. On each 

successful debit executed by the predefined subscription cycle, a new order is created in your shop 

system, specifying the parent TID subscription.  

Use the Subscription payments option in the Novalnet API Configuration tab to choose the payment 

methods you wish to offer for subscription payments. 

This option is only available for Credit/Debit Cards, Direct Debit SEPA, Direct Debit ACH, Invoice, 

Prepayment, PayPal, Direct Debit SEPA with payment guarantee, Invoice with payment guarantee, 

Google Pay, and Apple Pay. 

 
Figure 63 
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Select Subscription Tariff ID  
Choose the preferred Tariff ID (unique identifier for the tariff plan) that you created earlier in the Novalnet 

Admin Portal for your project’s subscriptions. 

 
Figure 64 

Please visit:https://developer.novalnet.com/corecompetencies/dynamic to know more about the dynamic 

subscription creation in the Novalnet Admin Portal. 

Cancel Subscription  

To cancel the subscription, select the respective entries in the subscription form. And, click the Cancel 

Subscription button as shown below. 

 
Figure 65 

After cancellation, the subscription status changes to Canceled under subscription details as shown 

in the figure. Refer to Chapter 6.2 Entries overview for more details about the form entries. 

 
Figure 66 
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8 UNINSTALLATION 

To uninstall the Novalnet Payment Plugin - Gravity Forms, please follow the steps below. 

Step 1: Navigate to Plugins → Installed Plugins as shown below 

 
Figure 67 

Step 2: Under the Novalnet payment Add-On for Gravity Forms, click Deactivate as shown below 

 
Figure 68 

Step 3: After deactivating, click Delete. 

 
Figure 69 

Step 4: Click OK to confirm that you wish to delete the Novalnet payment plugin-Gravity Forms 
permanently from your shop system. 

 
Figure 70 

9 TECHNICAL SUPPORTS THROUGH NOVALNET 

For any questions or further enquiries, please contact one of the following departments as per your 

requirement. Our in-house experts are ready to assist you in case of queries or issues.  

For installation assistance, contact technic@novalnet.de or call +49 89 9230683-19. 

For a merchant account, new payment plugin, or additional payment methods, please contact 

sales@novalnet.de or call +49 89 9230683-20. 

If you have any recommendations or suggestions for improvement, kindly share your thoughts with us to 

develop our payment plugin further at technic@novalnet.de or call us at +49 89 9230683-19. 

Are you happy with our service and support? Please spend a few minutes sharing your success here. 

For our License details, see for Freeware License Agreement. 
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